# Allow ports with non default VLAN as native VLAN, to not be a default VLAN member
no dual-mode-default-vlan
# Configure VLAN for Management VRF
** rd = route distinguisher (unique identifier) In MPLS networks, these are very important, as they RD is used across the networks. If no MPLS is used, the numbers are only locally significant.
vrf MVRF
rd 1:1
address-family ipv4
ip route 0.0.0.0/0 10.255.0.1
exit-address-family
exit-vrf
vlan 2 name MVRF
untagged ethe 1/1
router-interface ve 2
management-vrf MVRF
interface ethernet 1/1
port-name MVRF-Port
enable
no route-only
interface ve 2
port-name MVRF
vrf forwarding MVRF
ip address 10.255.0.10/24
ip tftp source-interface ve 2
ip syslog source-interface ve 2
Brocade VRF Resources:
http://www.brocade.com/downloads/documents/html_product_manuals/NI_05500c_ROUTING/wwhelp/wwhimpl/common/html/wwhelp.htm#context=L3RoutingGuideR05.5.00c&file=Management%20VRF.11.4.html
For dual homed BGP setup, access-list to avoid becoming a transport network:
ip as-path access-list 100 sec 5 permit ^$
ip as-path access-list 101 sec 10 permit .*
Prefix list for default route
ip prefix-list default-only seq 10 permit 0.0.0.0/0
Route Map to pre-pend AS# to control route
ip prefix-list aggregate_prefix seq 10 permit
ip prefix-list aggregate_prefix seq 20 permit
route-map prepend_out permit 10
match ip address prefix-list aggregate_prefix
set as-path prepend
set community ASn:n ASn:n ASn:n additive
route-map aggregate_out permit 10
match ip address prefix-list aggregate_prefix
*** ASn:n example 3356:50 , this info you will get or request from the upstream bgp peering partner
ip router-id
router bgp
local-as 1234
log-dampening-debug
neighbor 10.10.10.10 remote-as 4.3.2.1
neighbor 10.10.10.10 update-source
neighbor 10.10.10.10 soft-reconfiguration inbound
neighbor 10.10.10.10 password 2
address-family ipv4 unicast
aggregate-address
network
neighbor 10.10.10.10 route-map in
neighbor 10.10.10.10 route-map out aggregate_out
neighbor 10.10.10.10 filter-list 102 out
neighbor 10.10.10.10 route-map out prepend_out
neighbor 10.10.10.10 send-community
exit-address-family